Google Play services

no avatar
arnedery
Posts: 9
Joined: Thu Dec 22, 2016 1:53 pm

Re: Google Play services

Post by arnedery » Fri Feb 17, 2017 3:06 pm

@EloyAldao awesome findings.
I'll see and test this as well

no avatar
jerrel1991
Posts: 18
Joined: Sun Jan 01, 2017 5:20 pm

Re: Google Play services

Post by jerrel1991 » Sat Feb 18, 2017 7:33 am

The su command is not working for me.. :( "su: not found"

Naamloos.png
Naamloos.png (34.69 KiB) Viewed 1582 times

User avatar
EloyAldao
Posts: 14
Joined: Thu Jan 12, 2017 7:14 pm
Location: Spain

Re: Google Play services

Post by EloyAldao » Sat Feb 18, 2017 12:28 pm

jerrel1991 wrote:The su command is not working for me.. :( "su: not found"

Naamloos.png

The su command does nothing as we don't have root access. I put it following the tutorial, but it is useless.

You can jump over this command and you will get the same result

no avatar
bitflung
Posts: 46
Joined: Wed Feb 01, 2017 8:28 pm

Re: Google Play services

Post by bitflung » Sat Feb 18, 2017 7:16 pm

Awesome progress - I'll try this myself tonight too!!

no avatar
bitflung
Posts: 46
Joined: Wed Feb 01, 2017 8:28 pm

Re: Google Play services

Post by bitflung » Sat Feb 18, 2017 7:31 pm

Did you try the Android wear version of Google play services? E.g. here:
http://www.apkmirror.com/apk/google-inc ... s-release/

no avatar
bitflung
Posts: 46
Joined: Wed Feb 01, 2017 8:28 pm

Re: Google Play services

Post by bitflung » Sun Feb 19, 2017 4:10 am

bitflung wrote:Did you try the Android wear version of Google play services? E.g. here:
http://www.apkmirror.com/apk/google-inc ... s-release/


Ok, don't install that. It's the Android wear companion app for the phone. Doesn't help anything...

I've followed the above instructions and confirm it is installed and enabled. Note that it keeps crashing on me (every few minutes it seems to throw an error, lighting up the screen even when it was in ambient before)

I also tried installing a few versions of the play store. Got some installed but they all complained that they weren't right for the device (in-app error message saying to uninstall updates)

I've got strava installed and it is the only so that seems fully happy with this version of play services. No errors, no crashes. Not sure if the gps is working in the app but i know the heart rate sensor is (green lights come on). Will take it for a jog tomorrow). Also not sure if it can get online to upload my run... but this might be better than the built in fitness app?

OruxMaps seems to need wifi to pull up maps online. I can get that much to work but am confused in how to use the app so haven't gotten anything else (gps, save offline map, nothing else so far). Also it crashes on me a bunch.

Note that "su" command worked for me and i think it is necessary. Could be enabled only in the beta build ticwatch firmware? That's what I'm running anyway.

I've also got the Android wear app on my phone thing that the tucwatch is an Android wear device, but it won't connect. No errors reported on the watch for me, just the phone app being satisfied with the first stage of pairing and now when i launch the app it behaves as though my already-paired android wear ticwatch is simply not connected around to connect with.

no avatar
bitflung
Posts: 46
Joined: Wed Feb 01, 2017 8:28 pm

Re: Google Play services

Post by bitflung » Sun Feb 19, 2017 4:11 am

Screenshot_20170218-224022.png
Screenshot_20170218-224022.png (1.11 MiB) Viewed 1550 times


Android wear companion screenshot

no avatar
jerrel1991
Posts: 18
Joined: Sun Jan 01, 2017 5:20 pm

Re: Google Play services

Post by jerrel1991 » Sun Feb 19, 2017 9:33 am

Yep. I managed to enable GMS without the command window. I connected the Ticwatch with the AW companion app. Although it kept saying "trying to connect" I was able to install AW apps through the AW companion app. I'm able to browse AW apps in the AW store and can hit the sync button to upload the apps to my Ticwatch. Unlike the Ticwatch companion the AW syncing does not remove any of the side loaded apps. When I downloaded Strava I got a message to enable GMS. I just hit the enable button and viola. GMS is enabled. Then the crashes kept coming haha.

I did not manage to establish a working connection between my phone and the watch. But I noticed that some of the previous 'errors' were gone. For example the Google Keep app on the watch showed me a disconnected cloud icon instead of the 'android wear device not found' error.

Strava works. I'm not sure if the GPS works but the heart rate monitor works like a charm. Runkeeper works aswell.
I've tried side loading Shazam before and that ended up in the app crashing all the time. This time I was able to install it through the AW store. The app opens but does not react to music.

User avatar
EloyAldao
Posts: 14
Joined: Thu Jan 12, 2017 7:14 pm
Location: Spain

Re: Google Play services

Post by EloyAldao » Thu Feb 23, 2017 11:23 am

Sorry.
I published two times the same and I can delete this post.
The next one is the good one.
Last edited by EloyAldao on Thu Feb 23, 2017 8:03 pm, edited 1 time in total.

User avatar
EloyAldao
Posts: 14
Joined: Thu Jan 12, 2017 7:14 pm
Location: Spain

Re: Google Play services

Post by EloyAldao » Thu Feb 23, 2017 11:39 am

Other thing I tryed but does not work:

There is an app on Google Play Store called Aida64 (maybe you know it from Windows environment). It is an app to describe all the technical details of a device, so you can fun a while with it. It hasalso AW compatibility and it sideloads the correspondent app to the watch.

If you open the app on Watch you will se many options as System, CPU, Display,... and there is one called Android. If you open it there is a item called Rooted Device and say Yes!!! So the watch comes rooted from factory!!!

Well, this is not the question but has implications.

I thought, as on Cyanogenmod, that I could install the Open Gapps, so I downloaded the correspondent open_gapps-arm-5.1-nano-20170223.zip.
To install it you need a custom recovery, but I will not install it.

Instead I did the next:
    *I connected to the device via adb
    *I launched the command adb reboot recovery
    *The device then reboots and enters recovery menu. There are four options. The second says
    Install update via adb
    , so that is the one I was looking for
    *Move to that item using the crown (one click advances and a long click enters. I don't know how to come back)
    *There the watch says
    Use adb sideload <wherever>
    *The I try to do this but... there is no WiFi and no Bluetooth so... we need the developers dock (I have not ine)

Does somebody know how to achieve this?
If you try this and you want to restart from recovery remember that maintaining the crown pressed about seven seconds the watch reboots always.

Post Reply