Search found 8 matches

by pwhittic
Thu Feb 06, 2020 3:22 pm
Forum: TicWatch Pro
Topic: Ticwatch pro charging issues
Replies: 10
Views: 1851

Re: Ticwatch pro charging issues

@garrywadams,

My cable is plugged into an Anker PowerPort 5 (see - hopefully - attached).

Should this be OK for charging my watch? If not, can a USB port on my PC work? If not, what should I be using?


Patrick

Image
by pwhittic
Thu Jan 23, 2020 3:14 pm
Forum: TicWatch Pro
Topic: Ticwatch pro charging issues
Replies: 10
Views: 1851

Re: Ticwatch pro charging issues

I've got what sounds like the same issue. I say 'sounds like', as it will charge - but for the past few days, only seems to get as far as 46% and won't charge further. Hmm... just taken it off the charger and put it on my wrist and it's now showing 65%; however, given that it's been charging for > 1...
by pwhittic
Sun Oct 06, 2019 7:28 am
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Re: Can't set up Google Pay - what am I doing wrong?

Aathif,

Apologies for the delayed response.

Yes, switching off the 'Enable Mobile Management' worked for me!

Many thanks,


Patrick
by pwhittic
Mon Sep 09, 2019 7:20 pm
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Re: Can't set up Google Pay - what am I doing wrong?

Yes, it's a GSuite account - but that same account works on my phone for both Google Play and Google Pay. Google Play also worked perfectly on my previous watches (Moto 360 and LG).


Patrick
by pwhittic
Thu Sep 05, 2019 6:20 pm
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Re: Can't set up Google Pay - what am I doing wrong?

Oh, as a PS: in case it's linked, I keep seeing an "Account action required" from Google Play services.

If I click on the 'Open' button, nothing happens.
by pwhittic
Thu Sep 05, 2019 6:15 pm
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Re: Can't set up Google Pay - what am I doing wrong?

Aathif,

Sorry for the delay.

The Build Number is PWDD.190617.007

What sort of screenshots are you wanting?


Patrick
by pwhittic
Mon Aug 26, 2019 5:05 pm
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Re: Can't set up Google Pay - what am I doing wrong?

Hi Aathif, Many thanks for the response. Unfortunately, that's not made any difference - it still shows exactly the same messages. BTW, I think your instructions need one more step: after selecting Google Pay, you need to go in to App Info before you see the options to clear the data and cache. Patr...
by pwhittic
Mon Aug 26, 2019 6:52 am
Forum: TicWatch Pro
Topic: Can't set up Google Pay - what am I doing wrong?
Replies: 11
Views: 1612

Can't set up Google Pay - what am I doing wrong?

When I try to set up Google Pay, I have to click the 'Set it up' option, which then takes me to a screen asking me to choose an account (there's only one on there), then takes me to a screen telling me to 'Check your network connection. Please make sure you're connected then try again'. If I press C...