Page 1 of 1

Can't edit my account settings

Posted: Tue Sep 24, 2019 11:33 pm
by twyzeas

I've tried to register an account with my email address to log in to Mobvoi to access swim tracking on my E2. I own an old E too, and I've probably had an account already, as the email was taken. So I went the forgot password route, got the reset number to my email. When I entered it to Mobvoi's form, it directed me to a page—kind of like account settings—with all fields blank except account name, which was a random hash, and the email address. I had 'edit' and 'cancel' buttons only, I clicked 'edit'. I've added a user name, but the form couldn't be saved. I filled all fields except phone number to no avail. No error code or any proper hint, just a Chinese (!) popup saying 修改失败. I tried adding a phone number too, but a) I don't want to add my phone number to a random third party company like Mobvoi, and b) the form didn't recognize the regular, international phone number format anyway. Also, even if it had saved my details, where was I supposed to set a new password I could use to log in on my phone/watch?

At this point I'm pretty worried about your account security. How is it possible, that an international company that sells hardware around the world doesn't have a secure (but at the very least, working) account system?

Re: Can't edit my account settings

Posted: Thu Oct 03, 2019 11:29 pm
by twyzeas
I'd appreciate some help, mods.