Page 1 of 1

Google assistant broken after update

Posted: Wed Mar 20, 2019 10:31 am
by Cward71
Has anyone else got this issue? Google assistant was working fine until the recent WearOS update now it just returns a "sorry there was a problem" message.

I reset my watch and it worked fine until it auto updated to the new version and once again I get the same error message.

Any ideas of a fix?

Re: Google assistant broken after update

Posted: Thu Mar 21, 2019 10:39 am
by martin.keller
I have the latest WearOS 2.6 and the System "Android H" Update installed, and Google Assistant works for me.

Re: Google assistant broken after update

Posted: Fri Mar 29, 2019 5:25 pm
by Ves
I had this on the first watch I got.

Need to do some tests on the second one to see if it was hardware related or software.

On the WearOS forum and Reddit I've seen more posts regarding this.

Re: Google assistant broken after update

Posted: Tue Apr 16, 2019 11:02 am
by Mobvoi
Cward71 wrote:
Wed Mar 20, 2019 10:31 am
Has anyone else got this issue? Google assistant was working fine until the recent WearOS update now it just returns a "sorry there was a problem" message.

I reset my watch and it worked fine until it auto updated to the new version and once again I get the same error message.

Any ideas of a fix?
Hi Cward71,


Please make sure the watch is connected with phone or connected with independent WiFi net work. Let me know if this makes a difference.


Team Mobvoi

Re: Google assistant broken after update

Posted: Thu Apr 18, 2019 3:27 pm
by Graham101
I have the latest version of Wear OS and Android 9. I am unable to link Mobvoi with Google Assistant, after signing in with my Mobvoi account it doesn't appear in the list of linked services. Is there a fix available?