New TicWatch C2 stuck in "getting watch details screen"

Moderators: garrywadams, Aathif Mahir, Sabertooth

Post Reply
no avatar
Posts: 1
Joined: Sat Jul 20, 2019 5:49 am
Cash on hand: Locked

New TicWatch C2 stuck in "getting watch details screen"

Post by thorel82 » Sat Jul 20, 2019 6:03 am

I just bought a TicWatch C2 and I can't pair it to the phone. It is stuck in "getting watch details screen"
I turn on the watch, open the wear OS app on the phone, chose the watch accept the Bluetooth connection say yes to all the questions. Then this screen "getting watch details screen" shows up and stays there for hours and then it comes with a message " no connections" . Then my only option on either the phone or the watch is to un-pair and restore watch to factory defaults. I have done this about 100 times now and start the process all over again and again and there is no different, it always gets stuck on "getting watch details screen" and stays there for hours until it comes up with the no connection error
c2.jpg (79.22 KiB) Viewed 5306 times

no avatar
Posts: 3
Joined: Sat Jul 27, 2019 6:22 pm
Cash on hand: Locked

Re: New TicWatch C2 stuck in "getting watch details screen"

Post by caverde.15 » Tue Aug 13, 2019 1:31 am

Hi, I have the same issue with my girlfriend's phone (Redmi Note 7) , but given that I have not been able to solve it in any way, I have decided to use the TicWatch C2 and obtain another watch for it.

At first the TicWatch C2 was connected to my girlfriend's phone, but by mistake she untied it in some way and when she tried to link it again this error began.

Here is a link to my post:
viewtopic.php?f=44&t=54110&sid=082b7bde ... 19b2240172

no avatar
Posts: 2
Joined: Wed Jan 01, 2020 3:38 pm
Cash on hand: Locked

Re: New TicWatch C2 stuck in "getting watch details screen"

Post by selvarajmas » Wed Jan 01, 2020 3:43 pm

i also faced the same issue,.
I tried 2 days at last Upgrade to Oreo OS method save me(In this process your warranty is now void)
If you any doubts in this method ask me.

Solving method:
Actually, you can google for it, but you can follow my steps
1) install ADB on your computer (base on OS you're using) Here's the link:
2) Download the ROM flash file. Here's the link
3) Turn on USB Debugging Mode on your watch
(in setting / System / About / continuously tap on Build Number until it shows a message "Developer mode turned on" then go back to Settings and scroll down to the bottom)
4) Connected your watch to your computer via a charging cable that comes with it.
5) Open Command Line on Windows or Terminal on macOS and change directory to where the ADB located.
6) then type "adb devices" and wait for it starting...
7) then "adb reboot bootloader" and wait for the watch to boot to bootloader, in this process, the watch will ask you to unlock the bootloader, type "fastboot oem unlock" and follow instructions on the screen. (in process your warranty is now void)
8) unzip ROM file and open flash-all.bat and follow the instructions on the command line.

Post Reply