NO 4G/LTE connection (No network connection) after restart or ON/OFF

Moderators: garrywadams, Aathif Mahir

Post Reply
no avatar
laurynas
Posts: 2
Joined: Mon Aug 02, 2021 12:20 pm
Cash on hand: Locked

NO 4G/LTE connection (No network connection) after restart or ON/OFF

Post by laurynas » Mon Aug 02, 2021 1:55 pm

---Problem full description:

I connected Vodafone DE OneNumber eSIM - calls and SMS was working, but there was no internet connection. After watch battery died and watch switched off, full charging the battery and switching watch ON again - no connection to network (no calls, no sms, no internet).
I tried to delete eSIM info and factory reset watch by unpairing and add watch pairing again by repeating all process with eSIM QR code read and so on.
After repeating the process calls and sms started to work, but internet connection still not working.
I contacted Vodafone and show them settings with eSIM status (Settings > Connectivity > Mobile > SIM status) and settings with Access Point Names. They assured me that all settings are correct and problem is not from their part but from watch itself, because if watch can connect to network and network state is connected, watch calls and SMS are working, access point name settings are good, but watch is not starting any internet connection sesions - this can be only watch fault by itself.

I started my own investigation on this problem and found out that it is some kind of firmware bug. I have read on a different forums that other people has the same problem with Wear OS H-MR2 firmware on TicWatch 3 Pro LTE, but one part of the problem with no internet connection disapears after connecting other mobile communication provider OneNumber eSIM (reading other mobile communication provider eSIM QR code).
I did everything by instuction on the forum: I had ordered other mobile communication provider eSIM with OneNumber with eSIM QR code and by adding 2 SIM cards to my phone (one of Vodafone and one of other provider) I been able to gain access to QR code scan in Wear OS app on phone. By scanning other provider eSIM QR code watch gained access to new provider access points and everything started to work - calls, sms and the internet connection!
I was happy by resolving this problem ....but.... then same problem occurred again after watch battery died and watch switched off. After battery full charge and switching watch ON again - no connection to network at all (no calls, no sms, no internet).
I again repeated factory reset and now I have same problem that I had with Vodafone OneNumber eSIM card: calls are working, SMS are working, but no internet connection.
Nothing helped: delete eSIM, unpairing watch and factory reset watch - ...nothing!

---Problem:

By spending so much time on trying to resolve this bug and reading all information I can find - I made decision that there are 2 main problems related with eSIM:
1. When connecting eSIM - calls and SMS are working, but there is no internet connection;
2. After restarting or swithing ON watch (for any reason it was OFF) - all eSIM settings seems to be corrupted and network connection cannot be established. No calls, no sms, no internet working.

In my opinion both problems are related to firmware.

Does anyone have solution for this problems or figured out how to fix it?

---Spec and Version:

TicWatch 3 Pro LTE
Model: WH11013
Wear OS 2.28
Home App 2.48.0.377032688
System Version H MR2
Build Number PMRL.210414.002

no avatar
sajawi5393
Posts: 1
Joined: Wed Oct 27, 2021 2:22 pm
Cash on hand: Locked

Re: NO 4G/LTE connection (No network connection) after restart or ON/OFF

Post by sajawi5393 » Wed Oct 27, 2021 2:26 pm

acknwoeldigng.

Post Reply