Tic pods ANC cutting out

Moderators: garrywadams, Aathif Mahir, Sabertooth

Post Reply
no avatar
mdcmassie
Posts: 2
Joined: Mon Jun 08, 2020 11:56 pm
Cash on hand: Locked

Tic pods ANC cutting out

Post by mdcmassie » Thu Jun 18, 2020 11:28 pm

Just got my new tic pods ANC today and the left pod keeps cutting in and out. The right pod is mostly good but it does cut in and out as well. I have tried forgetting and resynchronization but that didn't help. Currently running pixel 3 Android 11. No issues with any other Bluetooth earbuds. :(

User avatar
Aathif Mahir
Posts: 479
Joined: Mon Apr 22, 2019 12:08 pm
Cash on hand: Locked
Bank: Locked

Re: Tic pods ANC cutting out

Post by Aathif Mahir » Fri Jun 19, 2020 1:38 pm

mdcmassie wrote:
Thu Jun 18, 2020 11:28 pm
Just got my new tic pods ANC today and the left pod keeps cutting in and out. The right pod is mostly good but it does cut in and out as well. I have tried forgetting and resynchronization but that didn't help. Currently running pixel 3 Android 11. No issues with any other Bluetooth earbuds. :(
Hi mdcmassie,

Seems like your running beta firmware on your Smartphone, Please try connecting to another Smartphone that's running stable firmware and let us know

Aathif Mahir
Mobvoi Lead Moderator

no avatar
torrey.felton
Posts: 1
Joined: Sat Jul 04, 2020 2:16 pm
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by torrey.felton » Sat Jul 04, 2020 2:29 pm

I purcahsed a pair as well and they arrived June 26. I've experienced issues where the one earpiece goes in and out. This is even with an unobstructed signal path between the phone and buds. Also experienced an issue where I was outside performing yard work and weed eating with ear buds ANC active. Qhereevwr the weed eater string would strike something large the buds would try to counter the particular frequency and create a loud pulsing noise. Scared me to death every time it happened. Will therw be any firmware release to help alleviate some of these early issues?

no avatar
davidwei531
Posts: 2
Joined: Sun Jul 05, 2020 11:43 am
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by davidwei531 » Sun Jul 05, 2020 11:49 am

So it's not me then!
Got the pair of TicPods ANC a couple of days ago, went well in first two days, but all of a sudden, there is a chance the left one won't turn on pairing mode when taking out from the pod, only the right one always function correctly. It's like buying a lottery, 2 out of 10 times both earphones will flash blue LED and connect to my mobile successfully. I have tested it on at least three different devices and was able to get it replicated.

I think we might need to contact the customer service since it doesn't seem to be an isolated event.

I have captured a short video showing the problem. Will send it to the team and see how it goes. First time to buy a product from Mobvoi, TBH I feel a bit of disappointed :(

no avatar
brian
Posts: 14
Joined: Fri Oct 18, 2019 2:03 pm
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by brian » Tue Jul 07, 2020 12:12 pm

On my second day of ownership I started getting issues where either the left or the right Ticpod would connect to the phone never both.

After much digging around the internet I found references to a "reset" involving putting the Ticpods in the case & plugging a charger out/in 4 times, this seemed to "fix" the problem.

Since then I've had random cases where either channel may take up to 30s to connect & give me stereo :(

I'm using them with a totally stock samsung S10 with all the latest updates.

I know I bought them on the pre-order deal but I didn't expect to be a beta tester :(

no avatar
andrew.jacopino
Posts: 1
Joined: Tue Apr 14, 2020 10:45 pm
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by andrew.jacopino » Tue Jul 14, 2020 2:34 pm

Hi Everyone,

I am having the same issue having bought the TicPods ANC. Worked for a couple of days synchronised but then, they simply won't sync with each other. i can have either left or right, but not both. Interesting is that when I try to pair with a stock Nokia 6.1 there are 2 devices present; ANC and BT_LE, which I assume is each of the TicPods separately. Have tried all manner of fixes (5 taps . . . no, 4 USB-C charges . . . no but just simply won't connect both which is a pity since when they were working I really liked them. Hopefully a simple fixed since I have the TicWatch Pro and it is great. But these . . . make me concerned as nothing from the mobvoi on this.

And unlike others, i haven't been able to have any luck (i.e. 2 out of 10). I am getting 0 out of 10.

Anyway, let me know if anyone has any luck in sorting this out.

Thanks in advance!

no avatar
brian
Posts: 14
Joined: Fri Oct 18, 2019 2:03 pm
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by brian » Wed Jul 15, 2020 9:48 am

This worked for me (I didn't see any flashing LEDs though)

If there is no audio from an earbud, please perform TWS pairing again according to the following steps:

Make sure the Earbuds disconnected to your mobile;

The left and right earbuds are placed in the charging case;

Open the cover of the charging case;

Then unplug and insert the USB Type-C charging cable 3 times in a row, then insert the USB Type-C charging cable to charge. The red light near the USB Type-C connector will flash 7 times quickly;

At this time, remove the left and right earbuds from the charging box. The Red and Blue lights of the left and right earbuds will flash alternately. After a few seconds, one of the earbuds flashes twice every 5 seconds, and the other earbud will flash blue quickly, to indicating that the TWS of the left earbud and the right earbud have been paired successfully.

no avatar
ferenc.muskatal
Posts: 2
Joined: Tue Aug 04, 2020 8:27 am
Cash on hand: Locked

Re: Tic pods ANC cutting out

Post by ferenc.muskatal » Wed Aug 05, 2020 9:40 am

brian wrote:
Wed Jul 15, 2020 9:48 am
This worked for me (I didn't see any flashing LEDs though)

If there is no audio from an earbud, please perform TWS pairing again according to the following steps:

Make sure the Earbuds disconnected to your mobile;

The left and right earbuds are placed in the charging case;

Open the cover of the charging case;

Then unplug and insert the USB Type-C charging cable 3 times in a row, then insert the USB Type-C charging cable to charge. The red light near the USB Type-C connector will flash 7 times quickly;

At this time, remove the left and right earbuds from the charging box. The Red and Blue lights of the left and right earbuds will flash alternately. After a few seconds, one of the earbuds flashes twice every 5 seconds, and the other earbud will flash blue quickly, to indicating that the TWS of the left earbud and the right earbud have been paired successfully.
I can confirm that this was working for me also although a bit different blinking patterns.
Does anyone know how often we have to repeat this reset?

Post Reply