Page 1 of 1

stuck at start up ticwatch screen

Posted: Sat Dec 10, 2016 10:39 pm
by kaosky
Anyone has this issue?
I'm trying to start it up after it died from battery.
It just gets stuck at the "Ticwatch" loading screen, and blacks out and starts up again, stuck in a loop.
1.jpg
1.jpg (97.8 KiB) Viewed 7677 times
2.jpg
2.jpg (95.75 KiB) Viewed 7677 times
3.jpg
3.jpg (79.1 KiB) Viewed 7677 times
1.jpg
1.jpg (97.8 KiB) Viewed 7677 times

Re: stuck at start up ticwatch screen

Posted: Wed Dec 21, 2016 7:56 pm
by Fennek
Hey,

yes I have the same problem. I can actually start it again when I place it on the charger and then push the crown.
It will then start again BUT the battery will only last half an hour then it goes off again.

A reset didn't help.

Re: stuck at start up ticwatch screen

Posted: Sun Mar 05, 2017 12:58 pm
by ethanchim10
Hi,

Did you get this problem resolved? Mine shows similar problem today & I'm stucked!

Re: stuck at start up ticwatch screen

Posted: Wed Mar 08, 2017 9:23 am
by Gaby
ethanchim10 wrote:Hi,

Did you get this problem resolved? Mine shows similar problem today & I'm stucked!
What is your watch OS version?

Put Ticwatch on the charger, when it fully charged, long press the crown to restart the watch again.

If it still doesnt work, record a vedio, send it to support@mobvoi.com.

Re: stuck at start up ticwatch screen

Posted: Tue Nov 21, 2017 8:50 am
by vjatagon
Hi Team,

I am exactly facing the same issue.

I recently bought the Tickwatch 2(Oak) from Amazon website. I am not able to start the watch as it is continuously restarting.

I googled a lot on the internet and finally found this link, which apparently is the exact issue I am facing as well

Watch not starting (stuck on bootloop) (fixed)
viewtopic.php?t=57


Please let me know what should I be doing. Is this a hardware issue or a software issue which I can fix it myself with any instartuction.

Please find attached the video link of the same.

https://photos.app.goo.gl/z8XSwJfnwnzTQ5an1

Re: stuck at start up ticwatch screen

Posted: Tue Apr 03, 2018 9:02 am
by metz
Hi, I have the same issues. Any following on this?
Please help us mobvoi!