battery life issue

Moderators: garrywadams, Chintannapster, Aathif Mahir, Sabertooth

Post Reply
no avatar
westche
Posts: 1
Joined: Mon Dec 12, 2016 6:42 pm
Cash on hand: Locked

battery life issue

Post by westche » Mon Dec 12, 2016 6:50 pm

Hey Everyone,

All of a sudden, I have been having terrible battery life with my watch. I have disable ambient mode, turned off gps, wifi etc. Turned down the brightness and set the screen timer to 10 seconds. Even with all of this, my battery lasts 1/2 day tops. Any suggestions? my battery used to last all day +

no avatar
Legalfoot
Posts: 2
Joined: Mon Dec 12, 2016 11:38 pm
Cash on hand: Locked

Re: battery life issue

Post by Legalfoot » Mon Dec 12, 2016 11:44 pm

Same thing is happening to me. I have done what you have but no go May have to do a reset and see if it fixes it.

no avatar
thanos
Posts: 1
Joined: Fri Nov 11, 2016 7:54 am
Cash on hand: Locked

Re: battery life issue

Post by thanos » Tue Dec 13, 2016 8:58 am

I have the exact same problem. with most options disabled, the battery lasts only have a day. With more options ON and more usage the battery lasted for more than a day.

There must be a fix for that, as the watch has become useless.

Onyx - Tic_4.4.1_intl - Samsung Galaxy S7 Edge

no avatar
Legalfoot
Posts: 2
Joined: Mon Dec 12, 2016 11:38 pm
Cash on hand: Locked

Re: battery life issue

Post by Legalfoot » Wed Dec 14, 2016 1:46 am

I looked closer at everything and somehow "hot word" had gotten turned on. I think it was from the last update. I turned it off and the Watch lasts the whole day now.

Doc

no avatar
cvogelge
Posts: 2
Joined: Fri Jan 26, 2018 1:27 pm
Cash on hand: Locked

Re: battery life issue

Post by cvogelge » Wed Feb 07, 2018 4:50 pm

i dont know how you can turn off the hot word option, so if you have insights on that it would be much appreciated. i love the watch but the battery life has just turned for the worse for me as well.

no avatar
helhadid
Posts: 40
Joined: Sun Jun 04, 2017 1:01 am
Cash on hand: Locked

Re: battery life issue

Post by helhadid » Mon Apr 23, 2018 9:56 am

My TW2 used to last for a day, but recently it had been losing 10% an hour even with minimum use (Ok Tico: Off, Ambient: On). I tried rebooting and even resetting the watch but to no avail.

However, two days ago I thought of a different solution: I'm not an expert so DO AT YOUR OWN RISK...*********

I used the watch till the battery died. Then I waited a bit and started the watch again. Of course, it shortly died afterwards. Then I turned it on again and it showed a white screen with the text "Android optimising" or something. Only then I placed it on the charger.

This was two days ago so it's early to judge, but it seems that this has fixed it.

Post Reply