Page 1 of 1

Battery life won't get through work day

Posted: Wed Feb 08, 2017 9:36 pm
by Jlambrey
Hi,

I just received my replacement watch because my first one had a defect in the screen.
This new one has a really low battery life. It doesn't last through the work day with normal usage: 5-10 notifications per hour, all gestures and ambiant mode off, Tico off, etc. I put on the watch at 7:30 AM and it dies around 4:30 PM (I even powered it down when training on lunch time). The previous watch had a good battery life. Although not 20 hours, it would last me through the day.

I have seen previous posts on this subject. Have any fixes been found?
Will I have to send this one back too?? Although I love this watch, I am getting quite frustrated with these problems.

Thanks for any help!

J.

Re: Battery life won't get through work day

Posted: Thu Feb 09, 2017 1:25 am
by bitflung
Bummer. The battery life CAN be good. I keep ambient mode on all day, a half dozen notifications per hour, tilt and tico disabled, tickle strip disabled too if that matters.

I start my day at ~6:30am, put on the watch, and keep it on all day. I get home about 6pm.

A watch face with heart rate sensor on it leaves me with 20%-40% when i get home.

A watch face without heart rate sensor readings leaves me with 40%-60% battery left.

I don't use power saver mode.

Something surely sounds wrong with your watch (or did i just get really lucky with mine?)

Re: Battery life won't get through work day

Posted: Thu Feb 09, 2017 3:17 pm
by Anstds
Same here, I've don't have ambient mode on but I use the fitness app everyday at least 1 hour , by the end of the day I still got left like 45 % - 30 %.

Battery life it's not something to blown ur mind but for me it's just fine.

Re: Battery life won't get through work day

Posted: Thu Feb 09, 2017 6:46 pm
by Jlambrey
This reinforces my feeling that my watch has a problem.

Re: Battery life won't get through work day

Posted: Mon Feb 27, 2017 8:26 am
by Gaby
You can update to the latest version 4.6.0_intl. It may be power saving than the old version. If it still drop power greatly, switch to beta version by settings-update-version switch, then extra logs to support@mobvoi.com.

Instruction to extract logs:
http://forum.ticwear.com/viewtopic.php?f=11&t=1744