Heart Sensor not working after H update

Moderators: Aathif Mahir, Chintannapster, Sabertooth

Post Reply
no avatar
Keybee
Posts: 2
Joined: Sat Apr 06, 2019 8:00 pm
Cash on hand: Locked

Heart Sensor not working after H update

Post by Keybee » Sat Apr 06, 2019 8:03 pm

Hello. I have little problem with my Ticwatch pro after H update . my heart sensor not working after 2-3 days and reboot not help with this. Heart sensor not working even in essential mode. I tried reboot watch, factory reset (this fixed but after 2 days not working) and i dont know what next i should do.. is there way to downgrade or how can i fix this problem. Thanks

User avatar
Cathal_S
Posts: 52
Joined: Mon Jan 21, 2019 4:17 am
Cash on hand: Locked
Location: United Kingdom

Re: Heart Sensor not working after H update

Post by Cathal_S » Wed Apr 10, 2019 9:03 am

Hi Kaybee,

When the watch is off your wrist can you see the green light flashing on the back of the watch when testing the heart rate?

Please also check..
  • The back of the watch is clean.
  • The watch strap is fastened tightly around your wrist.
  • You haven't installed any third party heart monitoring or fitness apps that could be interfering with the Mobvoi heart sensor.

Cathal

no avatar
Keybee
Posts: 2
Joined: Sat Apr 06, 2019 8:00 pm
Cash on hand: Locked

Re: Heart Sensor not working after H update

Post by Keybee » Fri Apr 12, 2019 10:03 am

Green light not showing . Im using apps only Google fit.
It works when i clear data from heart app but works only one week..

no avatar
sem
Posts: 14
Joined: Tue Mar 19, 2019 5:31 am
Cash on hand: Locked

Re: Heart Sensor not working after H update

Post by sem » Tue Apr 16, 2019 1:07 am

I did not see the green LED is on when I am testing

I just notice my Tic pulse is not working also, sigh

no avatar
sem
Posts: 14
Joined: Tue Mar 19, 2019 5:31 am
Cash on hand: Locked

Re: Heart Sensor not working after H update

Post by sem » Tue Apr 16, 2019 5:01 am

my heart sensor work as normal after I restart my watch

Post Reply