TicWatch Pro 4G won't charge / turn on

Moderators: garrywadams, Chintannapster, Aathif Mahir, Sabertooth

Post Reply
no avatar
sharmeshm
Posts: 5
Joined: Wed May 13, 2020 12:59 pm
Cash on hand: Locked

TicWatch Pro 4G won't charge / turn on

Post by sharmeshm » Wed May 20, 2020 9:07 am

Hi

I have been using my TicWatch Pro 4G for about a week and think it's a great watch.
I wen't for a run this morning and by the end of my run, the battery was running low. So, when i got home i put it on the charging dock to charge.

I returned to the watch about 20mins later and the watch was dead. No charge.

Now, i can't get the watch to charge at all. I have tried charging via the mains and USB, but still no joy.

I had set my watch to reset before i put it on the charging dock as i wanted to reset the units on my watch from metric to imperial.

Also, when plugged into my computer via USB, my computer recognises that a device has been plugged in, but the watch screen doesn't show any sign off life.

I am hoping someone on here can help me resolve this quickly.

Thanks in advance.

Sharmesh

Post Reply